UUID Plugin Checklist

Livecraft is currently operating using Minecraft 1.7.5 server software that has been modified to support Minecraft versions 1.7.2 to 1.7.9. Although it works well, this is far from optimal as the new Minecraft versions (1.7.9 and 1.7.10) support name changing. Most plugins must be updated, meaning it is a very large update on the server side of things, resulting in many things that can prevent the update. A checklist will be provided here for what is currently working under 1.7.10 and what still needs to be updated.

At the current moment, name changing is NOT SUPPORTED. You WILL lose player data if you change your username, and the server WILL TREAT YOU AS A NEW PLAYER. In the event Mojang allows name changing in the near future, you accept this risk and the potential loss of data that goes along with it.


UUID-Ready:

  • Spigot for 1.7.10
  • CompatNoCheatPlus
  • [ # ] Craftbook
  • [ # ] LWC
  • MCBans
  • NoCheatPlus
  • Prism
  • ProtocolLib
  • Vanish
  • WorldEdit
  • [ # ] WorldGuard

[CLEAR] Not dependent upon UUID:

  • [ ? ] MotdManager
  • NCore
  • NTheEndAgain
  • Poke
  • [ ? ] SignEditor
  • WorldEdit

[BREAKING] Not UUID ready:

  • Essentials
  • mcMMO
  • [ x ] Multiverse

[NON-BREAKING] Not UUID ready:

  • GAListener
  • NoOp
  • TagAPI
  • Votifier

Status information:
[ ! ] = Unstable.
[ # ] = Version specific (1.7.8+ ONLY)
[ ? ] = Most likely to be replaced by an alternative
[ x ] = Most likely to be removed

One thought on “UUID Plugin Checklist

  1. Pingback: Weekly Wrap-up: Week 10 | Livecraft

Comments are closed.